首页 查询工具 VPS服务器 网址缩短 联系我们

CentOS7安装Redis集群提示requires Ruby version >= 2.2.2的问题

发表时间:2018-11-29 17:09 | 分类:数据库 | 浏览:443 次

在CentOS 7中安装Redis集群的时候需要使用 ruby 命令,所以需要先安装 ruby 和相关接口。一般的安装方式类似如下:

yum install ruby
yum install rubygems
gem install redis

但最后却报错了。

Fetching: redis-4.0.3.gem (100%)
ERROR:  Error installing redis:
        redis requires Ruby version >= 2.2.2.

原来Centos默认支持ruby到2.0.0,可gem 安装redis需要最低是2.2.2。解决办法是用RVM把ruby版本升高。

1、安装RVM

RVM是一个命令行工具,提供多版本ruby环境的管理和切换,还可以根据项目管理不同的gemset。 如果没有生成ssh key,这一步可能会失败,直接ssh-keygen生成key之后再执行安装即可。

yum install gcc-c++ patch readline readline-devel zlib zlib-devel   
yum install libyaml-devel libffi-devel openssl-devel make   
yum install bzip2 autoconf automake libtool bison iconv-devel sqlite-devel 

curl -L get.rvm.io | bash -s stable

遇到gpg有关的问题:根据提示执行。如果失败的话,执行以下命令后再安装一次rvm。

command curl -sSL https://rvm.io/mpapis.asc | gpg2 --import - 

rvm -v能看到rvm安装上了。

2、查看rvm库中已知的ruby版本

rvm list known

# MRI Rubies
[ruby-]1.8.6[-p420]
[ruby-]1.8.7[-head] # security released on head
[ruby-]1.9.1[-p431]
[ruby-]1.9.2[-p330]
[ruby-]1.9.3[-p551]
[ruby-]2.0.0[-p648]
[ruby-]2.1[.10]
[ruby-]2.2[.10]
[ruby-]2.3[.7]
[ruby-]2.4[.4]
[ruby-]2.5[.1]
[ruby-]2.6[.0-preview2]
ruby-head
…. 

3、安装ruby 2.4.4版本

rvm install 2.4.4

4、使用一个ruby版本

rvm use 2.4.4

5、设置默认版本

rvm use 2.4.4 --default

6、卸载一个已知版本

rvm remove 2.0.0

7、查看当前版本

ruby --version

8、安装redis

最后用gem安装redis就不会报错了。

#   gem install redis

Fetching: redis-4.0.0.gem (100%) 
Successfully installed redis-4.0.0 
Parsing documentation for redis-4.0.0 
Installing ri documentation for redis-4.0.0 
Done installing documentation for redis after 1 seconds 
1 gem installed

结束。。。

本文标签:

本文链接:https://zhangnq.com/2936.html

欢迎您在本博客中留下评论,如需转载原创文章请注明出处,谢谢!

一键脚本 博客历程 留言本 文章归档 网站地图 谷歌地图 浙ICP备13025236号
托管于阿里云&七牛云 浙公网安备 33021202001057号
Copyright © 2010-2019 章郎虫博客 All Rights Reserved.