编译安装php7.3错误libzip must be upgraded to version >= 0.11

发表时间:2020-03-26 15:41 | 分类:Linux | 浏览:527 次

在老的linux系统(比如ubuntu 14.04,centos6)中手动编译安装php7.3的时候,一般都会碰到“system libzip must be upgraded to version >= 0.11”这样的错误。根据提示我们可以清楚的知道是因为系统自带的libzip版本低了,所以这里我们需要安装最新的libzip。

Xnip2019-09-18_20-33-19

在安装libzip之前可以先卸载系统自带的libzip,不过博主这里不建议这样做,因为对于老的系统不清楚是否有其他程序会有依赖老libzip库。

官网下载并编译安装

wget https://libzip.org/download/libzip-1.3.2.tar.gz
tar xvf libzip-1.3.2.tar.gz
cd libzip-1.3.2
./configure --prefix=/usr/local/libzip-1.3.2
make && make install

然后编译php7.3的时候添加或修改libzip的库地址

./configure --with-libzip=/usr/local/libzip-1.3.2

成功后在make && make install就可以了。

本文标签:

本文链接:https://zhangnq.com/3251.html

欢迎您在本博客中留下评论,如需转载原创文章请注明出处,谢谢!

一键脚本 博客历程 留言联系 文章归档 网站地图 谷歌地图 浙ICP备13025236号-4
托管于阿里云&七牛云 浙公网安备 33021202001057号
Copyright © 2010-2020 章郎虫博客 All Rights Reserved.